• USA : +1 973 910 5725
  • INDIA: +91 905 291 3388
  • info@tekslate.com
  • Login

CCNP Tutorials

Welcome to CCNP Tutorials. The objective of these tutorials is to provide in depth understand of CCNP.

In addition to free CCNP Tutorials, we will cover common interview questions, issues and how to’s of CCNP.

Introduction

Cisco Certified Network Professional (CCNP) is an intermediate-level certification in the Cisco certified professional program. This certification is aimed at full-time network or system administrators, or those who work with local and/or wide-area network (LAN/WAN)infrastructure.

CCNP – Terminology

Link: Interface on a router

Link state: Description of an interface and of its relationship to its neighboring routers, including:

IP address/mask of the interface,

The type of network it is connected to

The routers connected to that network

The metric (cost) of that link

The collection of all the link-states would form a link-state database.

Capture 89

Router ID – Used to identify the routers in the OSPF network

-IP address configured with the OSPF router-id command (extra)

-Highest loopback address (configuration coming)

-Highest active IP address (any IP address)

-Loopback address has the advantage of never going down, thus diminishing the possibility of having to re-establish adjacencies. (more in a moment)

Capture 90
CCNA 3.0 covers Single Area OSPF as opposed to Multi-Area OSPF

-All routers will be configured in a single area, the convention is to use area 0

-If OSPF has more than one area, it must have an area 0

-CCNP includes Multi-Area OSPF

-We will include a brief introduction to Multi-Area OSPF so you can see the real advantages to using OSPF

Interested in mastering CCNP Training? Enroll now for FREE demo on 
CCNP Training.

CCNP- Link State

Capture 91

Flooding of link-state information

The first thing that happens is that each node, router, on the network announces its own piece of link-state information to other all other routers on the network. This includes who their neighboring routers are and the cost of the link between them.

Example: “Hi, I’m RouterA, and I can reach RouterB via a T1 link and I can reach RouterC via an Ethernet link.”

Each router sends these announcements to all of the routers in the network.

Building a Topological Database

Each router collects all of this link-state information from other routers and puts it into a topological database.

Shortest-Path First (SPF), Dijkstra’s Algorithm

Using this information, the routers can recreate a topology graph of the network.

Believe it or not, this is actually a very simple algorithm and we highly suggest you look at it some time, or even better, take a class on algorithms. (Radia Perlman’s book, Interconnections, has a very nice example of how to build this graph – she is one of the contributors to the SPF and Spanning-Tree algorithms.

Shortest Path First Tree

This algorithm creates an SPF tree, with the router making itself the root of the tree and the other routers and links to those routers, the various branches.

Routing Table

Using this information, the router creates a routing table.

CCNP- Configuring Single Area OSPF

Enabling OSPF

Rtr(config)# router ospf process-id

-process-id: 1 – 65,535

-Cisco feature, which allows you to run multiple, different OSPF routing processes on the same router. (But don’t!)

-Process-id is locally significant, and does not have to be the same number on other routers (they don’t care).

-This is different than the process-id used for IGRP and EIGRP which must be the same on all routers sharing routing information.

-Extra: FYI – Cisco IOS limits the number of dynamic routing processes to 30. This is because it limits the number of protocol descriptors to 32, using one for connected route sources, one for static route sources, and 30 for dynamic route sources.

Configuring the Network Command

Rtr(config)# router ospf process-id
Rtr(config-router)# network address wildcard-mask area area-id

-Tells OSPF which interfaces to enable OSPF on (send and receive updates), matching the address and wildcard mask.

-Also, tells OSPF to include this network in its routing updates

-Wildcard is necessary because OSPF supports CIDR and VLSM

-Most of the time you can just use an inverse-mask (like access-lists) as the network wildcard mask.

Rtr(config-if)#ip add 10.5.1.1 255.255.255.0
Rtr(config)# router ospf 10
Rtr(config-router)#network 10.5.1.0 0.0.0.255 area 0

Network Command and the Wildcard Mask

Capture 92Capture 93

First three octets of the address must match 192.168.3.0 0.0.0.3

-Last octet of the network address is 0 = 00000000

-Last octet of the wildcard mask address is 3 = 00000011

-Must match the first 6 bits of the address 000000

-Don’t care about the last two bits of the address 11

-‘Addresses’ that would match 00000000, 00000001, 00000010, 00000011

      192.168.20.0, 192.168.20.1, 192.168.20.2, 192.168.20.3

-‘Address’ that does NOT match: 00000101 or 192.168.20.5

DR/BDR Elections

Configuring a Loopback Address

Rtr(config)# interface loopback 0
Rtr(config-if)# ip add 10.1.1.1 255.255.255.0

-Automatically are “up” and “up”

-Very useful in setting Router IDs as they never go down.

-RouterID is used to identify the routers in the OSPF network

-IP address configured with the Router-ID command (extra)

-Highest loopback address

-Highest active IP address

-Important for DR/BDR elections unless you use the ip ospf priority command (next)

-Extra: Also, useful to configure “virtual” networks that you can ping and route as if they were attached networks.

DR/BDR Elections

DR/BDR Elections

-Router with the highest Router ID is elected the DR, next is BDR.

-But like other elections, this one can be rigged.

Rtr(config)# interface fastethernet 0
Rtr(config-if)# ip ospf priority <0-255>

Higher priority becomes DR/BDR

Default = 1

Ineligible to become DR/BDR = 0

Modifying the Cost

Rtr(config-if)# bandwidth 64 = Rtr(config-if)# ip ospf cost 1562bandwidth command
Rtr(config-if)# bandwidth kilobits   
                (ex: 64 = 64,000bps)

-Changes the default bandwidth metric on a specific interface.

-Used in the 108/bandwidth calculation for cumulating the cost of a route from the router to the network on the outgoing interfaces.

-Does not modify the actual speed of the link.

ip ospf cost command
RTB(config-if)# ip ospf cost value  
               (ex: 1562, same as bandwidth = 64kbps)

-Configures the cost metric for a specific interface

-Uses this value for the cost of this interface instead of the 108/bandwidth calculation

-Common for multi-vendor environments.

Contact US

Need an Instructor Led Training, Contact Us





Support


Please leave a message and we'll get back to you soon.

I agree to be contacted via e-mail.